Themabewertung:
  • 1 Bewertung(en) - 5 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Heimcomputer KC85/3
#1
Angeregt von Ingo, habe ich nach meinen alten Computer geschaut ob der noch funktioniert. Nach Sicherungswechsel ( war vergrießgnaddelt ) funktioniert er wieder wie damals vor ca. 34 Jahren.
Der hatte immerhin schon 16 KB Rom, der Vorgänger nur 4 KB Rom.
Aber konnte schon mit 16 Farben umgehen. Mein Basic ist aber schon mächtig eingerostet, war damals aber interessanter Zeitvertreib um einfache Spiele zu erstellen.
Ich habe da auch noch mehrere Kassetten da die mit einem Kassettentonband in den Computer geladen wurden.

Hier mal der Computer auf einem Farbfernsehgerät, den sich aber kaum einer leisten konnte.

   

das war der Startbildschirm

   

und mit so einem Junost ( oder ähnlichem ) wurde er am meisten betrieben.

   

Am häufigsten wurden diese Computer an Instituten oder ähnlichen Lehreinrichtungen benutzt.
Der Preis war doch recht hoch, sodas sich die wenigsten sowas leisten konnten.
Habe immer soviel Arbeit, das ich mir eine aussuchen kann. Smile

Grüße Frank, der Moschti
Zitieren
#2
Cool Frank  Smile

An einem KC85/3 haben wir damals unsere ersten Programmierungen gemacht,
im Betrieb eines Onkels am Wochenende. Boah, das war'n noch Zeiten...
Klasse, daß Du noch einen hast, der sogar noch funktioniert.

Viele Grüße, von Peter
~~~~~ DE - MV  /  Connected ~~~~~
Zitieren
#3
Hallo,

ich erinnere mich auch noch deutlich ! Wir hatten bereits in der Lee...hre Kombuster... Wenn ich den blauen Bildschirm mit HC C(H)AOS lese... Ich weiß noch, wie wütend ich damals (1987) und auch etwas später im Studium war, daß ich nix verstanden hab und auch nie den richtigen Einstieg gefunden hab  ... Ich war es von der Analogelektronik gewohnt, alles haarklein ergründen zu können, also erstmal mit kleinen Sachen anfangen, dann immer detaillierter, quasi das Ergründen des "was wie warum ... endgeil !" ... Das war schon bei solchen Z80 sportlich, aber es war schon machbar, nur nicht nebenbei... Beim Studium war ich dann zumindest soweit, daß "was - wie - warum" ein bischen (!) mehr zu verstehen. Aber das "...endgeil"-feeling kam nie auf...

Ich hab mein Lehrlingsprogramm (Berechnung Flächeninhalt, Umfang von Kreis, Dreieck, Viereck ... Volumen gewisser Körper bis Kegel) sogar noch irgendwo auf Kassette... 1987, ob das noch geht ?... Später hatte ich mir fürs TV-Basteln sogar ein Farbbalkentestbild geschrieben (beim FuBK bin ich bei den Unbuntfeldern gescheitert... Scherz..), das hab ich auch noch irgendwo ("Testbildkassette"), habs auch genutzt für PAL-Spielereien, allerdings ist das Laden so aufwendig, daß ich dann schnell zum Videorecorder übergegangen bin. Und die Qualität des FBAS ist auch nicht so doll, manche Empfänger haben mit dem Signal ein paar Probleme...

Egal, ne schöne Erinnerung trotzdem ^^ Aus heutiger Sicht kann man eigentlich jedem Technikinteressierten nur raten: Mach in Kombuster ! das ist die Zukunft, ob wir wollen oder nicht...

Gruß Ingo
Zitieren
#4
Meine erste intensive Erfahrung mit der sog. Computertechnik war das System 360 Mod 20 von IBM. Dieses Gerät hatte zw. 8 bis max 16 kB ( Kern-) Speicherkapazität und wurde mit den Programmen RPG oder Basic Assembler programmiert.
Ein Exemplar steht heute im Deutschen Museum in München. Es war ein auf Lochkarten basierendes kommerzielles Rechensystem welches in der Endausbaustufe mit Platten- u. Bandspeichermaschinen ausgerüstet werden konnte. Es fand weite Verbreitung, löste es doch die weitgehend elektromechanische Datenverarbeitung ab 1965 ab.
Gruß Franz
Zitieren
#5
Wollte meinen KC85/3 mal wieder in Betrieb setzen. Leider keinerlei Funktion.
Zwei Bauteile brenn durch. Ersatz sollte kommen. Habe zumindest was bestellt bekommen.
Hier mal die Schaltung dazu.

   
Habe immer soviel Arbeit, das ich mir eine aussuchen kann. Smile

Grüße Frank, der Moschti
Zitieren
#6
Hallo Frank,
wenn Du den Transistor schon mal draußen hast, kannst Du mit einem Labornetzteil am Emitter 5V anlegen und sehen, was an Strom fließt.
Die SZ600/6,2 stellt den Schutz vor Überspannung sicher . Ist also wichtig und evtl. extern prüfen.
Der Schaltregel IC könnte auch defekt sein, wenn da nichts schwingt, brennt der Transistor durch.
Gruß Klaus
Zitieren
#7
Hallo Frank,

wenn es nicht völlig original sein muss, würde ich der Z-Diode zum Schutz der 5V-Schiene eine Schutzdiode (Suppressordiode / Transient Voltage Suppressor (TVS)) vorziehen wie zum Beispiel die 1,5 KE 6,8A ( Datenblatt ).


Wenn R13 durchbrennt, ist auch VT10 SD336C suspekt.

Viele Grüße

Ingo.
Die Konvergenz der Apokalypse führt unweigerlich zur Hybris.
Zitieren
#8
Ich werde alle Halbleiter durchprüfen. Bestellt sind die ja.
Hier noch ein Bild vom Netzteil. Es ist recht übersichtlich aufgebaut und gut beschriftet.

   
Habe immer soviel Arbeit, das ich mir eine aussuchen kann. Smile

Grüße Frank, der Moschti
Zitieren
#9
Hallo, Frank,

Ich würde unbedingt empfehlen, das Netzteil vom Rest des Computers abzutrennen, und mit einer Ersatzlast zu betreiben. Nicht dass durch blöden Zufall der wichtige teil des Computers stirbt.

Häufig machen die Elkos in Schaltnetzteilen Probleme. Wenn deren innere Widerstände ( ESR ) zunehmen, wird dort Wärme erzeugt, es entstehen Spannungsspitzen, für die die Halbleiter nicht gemacht sind, etc.

VG Henning
Schlau ist, wer weiß, wo er nachlesen kann, was er nicht weiß.
Nur Messungen liefern Fakten, alles andere ist Kaffeesatz.
Zitieren
#10
Wie könnte ich die Ersatzlast den am besten bewerkstelligen.
Kleine Lampen oder LED mit Vorwiderstand.

Elkos und Transistoren und Dioden sind alle in Ordnung. Habe sie einzeln geprüft.
Außer der SD347, den ich aber bekomme.
Wird wohl der B260 defekt sein.
Habe immer soviel Arbeit, das ich mir eine aussuchen kann. Smile

Grüße Frank, der Moschti
Zitieren
#11
....gebe doch bitte zunächst die 5 V Strom begrenzt, per Fremd Netzteil ein, nachdem du den verdächtigen, die Z-Diode ausgelotet hast, und schaue dann weiter.....
M.f.G.
harry


--------------------------------------------------------------------
Es ist keine Schande, nichts zu wissen, wohl aber, nichts lernen zu wollen.
--------------------------------------------------------------------
Zitieren
#12
Hallo, Frank,

als Ersatzlast eignet sich am Besten ein normaler Widerstand, hier ca 5 Ohm. Der sollte genügend belastbar sein.

Wenn das Netzteil normal läuft, sollte die Belastung von 1 A zu stabilem Betrieb führen.

Ich würde ein analoges Multimeter fest mit anschließen, dann sieht man sofort, ob die Spannung stimmt.

Und wie gesagt, auch scheinbar gute Elkos können einer solchen Schaltung den Garaus machen.

Aber möglicherweise, wenn ich das richtig verfolgt habe, wissen wir ja noch nicht, ob die Überlastung nicht im Rechnerteil selbst liegt, oder dadurch entsteht, daß die Spannung hochläuft, und dann die Z-Diode am Netzteilausgang den Strom zieht.

Wenn der Rechnerteil abgetrennt ist, kann man die Diode einseitig unterbrechen, um die dann anstehende Spannung zu messen.

VG Henning
Schlau ist, wer weiß, wo er nachlesen kann, was er nicht weiß.
Nur Messungen liefern Fakten, alles andere ist Kaffeesatz.
Zitieren
#13
Brennen die Bauteile auch durch, wenn kein Computer am Netzteil hängt?
Wenn nein, dann liegt der Fehler auserhalb des Netzteils.
Wenn ja, dann würde ich zunächst mit dem Ohmmeter ab L12 nach einem Kurzschluss fahnden und die Bauteile die, ab L12 nach Masse liegen, verdächtigen.

Liegt der Fehler auf dem Mainboard, würde ich Selbiges mit einem Labornetzteil und Strombegrenzung betreiben, das wurde ja bereits empfohlen.
Verdächtig sind natürlich Kondensatoren, das sind die am ehesten durch Rumliegen sterbenden Bauteile.

Man kann natürlich auch stur alles durchmessen und austauschen ;-) Das ist reine Geschmackssache :-)

So ein KC85 wäre auch noch ein tolles Exponat für unsere Computersammlung an der Uni. Leider haben wir noch keine "Ostblock"-Rechner.

Gruß,
Daniel
Smiley47
Zitieren
#14
Hallo Morningstar

Wenn du dich "von der anderen Seite nähern willst" ist ein AT-Netzteil vom alten PC (vom Schrott) 'ne feine Lösung um das Board zu testen. Da hast du 
+ / - 5, und + / - 12 Volt in ergiebiger Amperezahl zur Verfügung. AT Netzteil hat den Vorteil, daß es einen Netzschalter hat. Wenn du dir da ein Testbrett machst mit dem nötigen Anschluß für's Netzteil und ein paat Sicherungshalter für jede Spanung die du entnehmen willst (evtl. Bananenbuchsen für's Meßgerät) kannste das für viele Aifgaben verwenden. Ein ATX-Netzteil geht zur Not auch, wenn man die Start-Leitung nach Masse schaltet. Glühlampen (Bilux, H4,Rücklicht o.ä. oder eine alte Festplatte (habe ich so) bilden die Grundlast, damit das Netzteil nicht leer läuft. Als Last zum Netzteiltest eignen sich Lampen eher weniger, da der Kaltwiderstand meist zu gering ist.
Solltest du dazu Fragen haben, melde dich einfach.
Das Original-Netzteil (nach Elko-Prüfung) am besten ohne SD347 und VD11 mal mit Strom versorgen (Achtung --> VD10 prüfen) und am Schaltkreis pin 13 mit'm Oszillografen die Impulse prüfen. Wenn vorhanden, dann an der Basis vom SD336 und zum Schluß an dem Anschlußpunkt  der Basis des SD347. SD347 ist normalerweise durch R13 gesperrt und wird durch SD336 mit Impulsen aufgesteuert. R13 brennt erst durch, wenn entweder der SD347  C --> B durchlegiert hat oder der SD336 einen C --> E Schluß hat bzw. dauernd aufgesteuert wird.

Viele Grüße Peter
Die Deutsche Sprache ist FREEWARE, du darfst sie ohne Einschränkungen verwenden.
Die Deutsche Sprache ist nicht OPENSOURCE, du darfst sie nicht nach deinem Gutdünken verändern!
Zitieren
#15
Danke euch für die guten Hinweise, vor allem die Fehlerbeschreibung von Peter.
Werde das mal durcharbeiten.

Werde aber erst einmal nicht mit einem Externen Netzteil das Board befeuern.
Das Originale ging ja mal und sollte auch wieder fit werden.
Soviel ist da ja nicht drin. Smile
Habe immer soviel Arbeit, das ich mir eine aussuchen kann. Smile

Grüße Frank, der Moschti
Zitieren
#16
So gute Nachricht. Er lebt wieder.

   

Das Bild ist nicht besonders, da der Junost schnell aus dem Regal gezogen wurde.

   

Alle Kontrollen sind da.

   

Hier das Oszibild von PIN 13 des B260.

Sieht zwar nicht aus wie ein Sägezahn, aber das Netzteil arbeite mit den richtigen Spannungen.
Defekt waren die Z-Diode VD11. (6,2 V )
Die VD42 (5,6 V ) habe ich auch gleich gewechselt, da dort eine SZX19 drin war.
Glücklicherweise habe ich ja Originalteile, die ich auch laut Plan, ausmessen konnte.
Der C32 470µf war auch taub, aber 12 Volt Spannung ging noch. Wurde ebenfalls ausgetauscht.
Alles im Allen habe ich die Elkos und Halbleiter einzeln geprüft und ggf. bei zu großen Abweichungen dann ersetzt.
Der Chip B260 war in Ordnung, sonst würde der jetzt nicht gehen. Ersatz habe ich aber mit trotzdem schicken lassen.

Noch zur Ergänzung:
Spannungswerte nach Bauteiltausch, plus +5,34 Volt, -5,32 Volt und +11,99 Volt.
Sollte so in Ordnung sein.

Hat mal wieder richtig Spaß gemacht, nach dem derzeitigen Caos und Tragödien die wir in der Familie haben.
Habe immer soviel Arbeit, das ich mir eine aussuchen kann. Smile

Grüße Frank, der Moschti
Zitieren
#17
Kurz noch dazu.
Heute waren meine Enkel mal da, 12 und 14 Jahre.
Unverständnis von ihnen:
Wie ? da muss ich Befehle eingeben ? Und wie geht das?
Naja, wie erklärt man den jungen Leuten von heute wie das funktioniert.
Man versucht es, aber es wird nicht mehr verstanden, das es damals doch etwas komplizierter war wie eben
heute die PC Spiele, Frazenbuch, blaue Taube oder eben Watsab.
Kann ich aber auch ein irgend ein wenig verstehen.
Heute wird den Kinder eben alles Mundgerecht hingelegt. Leider.
Selbst ein alter Röhrenfernseher Flackert halt eben und ist " Fürchterlich".
Habe immer soviel Arbeit, das ich mir eine aussuchen kann. Smile

Grüße Frank, der Moschti
Zitieren


Gehe zu: